Pkg upgrade updating repository catalogue no valid repository found cherry blossem dating

Rated 4.88/5 based on 552 customer reviews

Use the This message indicates that you attempted to install a version of a package that does not match the version to which the package is constrained by an incorporation package.

See Incorporation Packages for information about incorporation packages and constraints.

If the version you want is still listed, then this package is not constrained and you should be able to install it without installing or updating any other packages.

If the version you want is not listed, then this version is available from configured publishers but not installable in this image.

We have a local pkg repo that contains a copy of all packages and the various upper-level files from The following 2 packages will be affected (of 0 checked): New packages to be INSTALLED: clang33: 3.3_9 [itadmin] llvm33: 3.3_10 [Free BSD] The process will require 155 Mi B more space. Once I change the order of the directories to look at /usr/local/etc/pkg/repos/ first, all packages are found in the higher priority repo.

Free BSD.org/Free BSD:10:amd64/latest/ I have defined this repo to have a priority of 9 and stored the definition for this repo in /usr/local/etc/pkg/repos/. I think I see the same issue, but I end up having installed broken package. Checking for upgrades (52 candidates): 100% Processing candidates (52 candidates): 100% The following 17 package(s) will be affected (of 0 checked): Installed packages to be DOWNGRADED: nettle: 3.2 - 1.13_1 [Free BSD] Installed packages to be REINSTALLED: xvid-1.3.4,1 [Free BSD] x265-1.8 [Free BSD] nginx-1.8.1,2 [poudriere] mpv-0.15.0,1 [poudriere] (needed shared library changed) libx264-0.144.2533_1 [Free BSD] libdvdread-5.0.3 [Free BSD] lame-3.99.5_3 [poudriere] jsoncpp-0.6.0.r2_2 [Free BSD] ffmpeg-2.8.6,1 [poudriere] curl-7.47.0 [Free BSD] cmake-3.4.2 [poudriere] (needed shared library changed) The operation will free 1 Mi B.

For more information, invoke the command again, specifying only the package that cannot be installed, specifying the full FMRI of that package, and providing one or more command to remove that origin.

For this reason, you should not update one package that is constrained by an incorporation.

Yet, when I run a pkg install of a package with dependencies, it will get the requested package from our local repo, but the dependencies from the Free BSD repo. Problem can only be alleviated by using "pkg install -r Local .....". I have "Local" repository with priority 10, which contains net-mgmt/zabbix22-proxy with same version as "Free BSD" repository, but with different build options.

As in: % sudo pkg install clang33 Updating Free BSD repository catalogue... When installing zabbix22-proxy, pkg complains about unsatisfied dependencies and all dependant packages except zabbix22-proxy, are installed from "Free BSD" repository.

Take one of the following actions to address this issue: If you specify multiple packages to install or update, or if you omit the package specification for an update operation, the installation or update operation fails if any of the packages cannot be installed in this image.

If one package cannot be installed, no packages are installed.

Leave a Reply